Sicherheitswarnung · Kritisch
Langflow: zwei kritische Schwachstellen ermöglichen Codeausführung ohne Anmeldung, Aktualisierung auf 1.13.0 erforderlich
· 3 Minuten Lesezeit · Centoculus Security Team
Bekannt seit
Betroffen: Langflow 1.0.0 bis 1.12.8 (behoben in 1.13.0)
Was ist passiert?
Am 2. November 2026 wurden zwei kritische Schwachstellen in Langflow öffentlich bekannt gemacht. Langflow ist ein Open-Source-Werkzeug zum Erstellen von KI-Workflows, Agenten und Chatbots. Die Schwachstellen ermöglichen es einem Angreifer, die Authentifizierung zu umgehen oder beliebigen Code auf dem Server auszuführen, ohne ein Konto zu benötigen. Langflow Version 1.13.0 behebt beide Probleme.
Die vorliegenden Daten enthalten bisher keine Berichte über aktive Ausnutzung. Langflow-Instanzen sind häufig aus dem Internet erreichbar, und frühere Schwachstellen in Langflow wurden kurz nach der Veröffentlichung angegriffen. Wir empfehlen Ihnen, dieses Update dringend einzuspielen.
Wer ist betroffen?
Alle Langflow-Versionen von 1.0.0 bis einschließlich 1.12.8 sind betroffen. Dies gilt für Installationen per pip, Docker-Container und andere selbst betriebene Umgebungen.
Das Risiko ist am höchsten für Instanzen, die ohne zusätzliche Zugriffsschicht davor aus dem Internet erreichbar sind. Die Codeausführung in Langflow läuft mit den Rechten des Langflow-Prozesses. Dieser Prozess hat häufig Zugriff auf:
- API-Schlüssel für Sprachmodell-Anbieter
- Datenbank-Zugangsdaten
- weitere Geheimnisse, die in Flows und Umgebungsvariablen gespeichert sind
Was Sie jetzt tun sollten
- Alle Langflow-Instanzen finden, die Sie oder Ihre Kunden betreiben, einschließlich Test- und Demo-Umgebungen, die leicht in Vergessenheit geraten.
- Sichern Sie Ihre Langflow-Konfiguration, Umgebungsdateien sowie Datenbank bzw. Datenvolume, bevor Sie aktualisieren.
- Aktualisieren Sie auf Langflow 1.13.0.
- Bei pip-Installationen führen Sie
pip install --upgrade langflow==1.13.0in der Umgebung aus, die Langflow verwendet. - Bei Docker ändern Sie das Image-Tag auf 1.13.0, laden das neue Image und erstellen den Container neu.
- Bei pip-Installationen führen Sie
- Starten Sie den Langflow-Dienst neu und prüfen Sie, ob die Weboberfläche lädt und Ihre Flows weiterhin laufen.
- Beschränken Sie den Zugriff, falls Langflow nicht öffentlich erreichbar sein muss. Binden Sie es an localhost oder ein internes Netzwerk, oder betreiben Sie es hinter einem Reverse-Proxy mit Authentifizierung oder einem VPN. Erlauben Sie in der Firewall nur bekannte IP-Adressen.
- Falls Sie nicht sofort aktualisieren können, blockieren Sie den Zugriff aus dem Internet auf den Langflow-Port, bis Sie es können.
- Rotieren Sie Geheimnisse, wenn eine betroffene Instanz aus dem Internet erreichbar war. Das betrifft API-Schlüssel, Datenbankpasswörter und Tokens, die in Langflow oder dessen Umgebung gespeichert sind.
So prüfen Sie, ob Sie betroffen sind
- Prüfen Sie die installierte Version.
- Bei pip führen Sie
pip show langflowaus. - Bei Docker führen Sie
docker psaus und prüfen das verwendete Image-Tag. - Jede Version von 1.0.0 bis 1.12.8 ist verwundbar.
- Bei pip führen Sie
- Prüfen Sie, ob der Langflow-Port von außen erreichbar ist, zum Beispiel per Portscan von einem externen Host.
- Sichten Sie die Langflow- und Reverse-Proxy-Logs auf ungewöhnliche Anfragen von unbekannten IP-Adressen, insbesondere Anfragen an API-Endpunkte von Adressen, die sich nie angemeldet haben.
- Suchen Sie auf dem Host oder im Container nach Anzeichen einer Kompromittierung:
- unerwartete Prozesse
- neue Cron-Jobs oder Benutzer
- unbekannte Dateien in temporären Verzeichnissen
- ausgehende Verbindungen zu unbekannten Adressen
- Prüfen Sie Flows oder Komponenten in Langflow, die Sie nicht erstellt haben.
Falls Sie Anzeichen einer Kompromittierung finden, nehmen Sie die Instanz vom Netz. Bauen Sie sie aus einem sauberen Image mit Version 1.13.0 neu auf und rotieren Sie alle Zugangsdaten, auf die sie zugreifen konnte.
Quellen
Weitere Beiträge
Sicherheitswarnungen ·
OpenSSH auf Alpine Linux: Anmeldung ohne Passwort durch überlange Passwörter
Auf Alpine-Linux-Servern mit dem Standardpaket openssh-server können Angreifer sich ohne Passwort bei Konten anmelden, etwa bei Konten, die nur mit SSH-Schlüsseln genutzt werden. OpenSSH 10.6p2 und aktualisierte Alpine-Pakete beheben das Problem.
Sicherheitswarnungen ·
APT-Lücke auf Debian und Ubuntu erlaubt Paketaustausch per MitM und Codeausführung als root
Eine Lücke in APT erlaubt einem Angreifer, der Paket-Downloads manipulieren kann, ein verifiziertes Paket zu ersetzen und Code als root auszuführen. Debian und Ubuntu haben am 4. November Sicherheitshinweise veröffentlicht. Aktualisieren Sie APT auf allen Servern.
Sicherheitswarnungen ·
Ruby on Rails Active Storage: kritische Schwachstelle beim Dateischreiben über ImageMagick-Uploads
Eine kritische Schwachstelle in Ruby on Rails Active Storage erlaubt nicht authentifizierten Angreifern, über einen präparierten Upload beliebige Dateien auf dem Server zu schreiben, wenn ImageMagick die Datei verarbeitet. Aktualisieren Sie auf Rails 8.1.4.1 oder 8.0.5.2.