Security alert · Critical
Barracuda Email Security Gateway: critical auth bypass allows config takeover
· 2 minutes read · Centoculus Security Team
Known since
Affected: Barracuda Email Security Gateway before 9.4.0.030
What happened
On 2 November 2026, a critical vulnerability in Barracuda Email Security Gateway was made public, tracked as CVE-2026-116606 with a CVSS base score of 9.3. It was reported via a Mandiant vulnerability disclosure, and Barracuda has published an advisory.
The flaw is an authentication bypass. An unauthenticated remote attacker can call the appliance's configuration-import function and restore a crafted, compatible backup archive. The result is an unauthorized change of the appliance's global configuration. News reports describe that this flaw can be chained with further issues to gain root access to the device; Barracuda's advisory linked below covers the details.
At the time of writing there are no confirmed reports of active exploitation. Barracuda email gateways have been targeted by attackers in the past, so a quick update is advisable.
Who is affected
- Barracuda Email Security Gateway in all versions earlier than 9.4.0.030.
- The risk is highest for appliances whose management interface is reachable from the internet or from untrusted networks.
An attacker who controls the configuration of a mail gateway can, for example, redirect or intercept mail flows, weaken filtering or create access for later attacks. This affects every mail domain routed through the appliance, including those of your customers.
What to do now
- Check the firmware version of each Barracuda Email Security Gateway in its web interface.
- Export a current configuration backup and store it outside the appliance.
- Update every appliance to version 9.4.0.030 or later, following the Barracuda advisory linked below.
- After the update, confirm the new version is shown and that mail is being received, filtered and delivered normally.
- Restrict access to the management interface to trusted administrative networks or a VPN, if it is currently reachable from the internet.
- Review the global configuration for changes you did not make (see below). If you find any, treat the appliance as compromised, restore a known good configuration, change administrator passwords and API credentials, and contact Barracuda support.
How to check whether you are affected
- Any appliance running a version below 9.4.0.030 is vulnerable.
- Compare the current configuration with your last known good backup. Pay attention to mail routing and relay settings, delivery destinations, filtering and allow lists, administrator accounts and remote access settings.
- Review the appliance's audit and access logs for configuration imports or restores that were not performed by your team, especially since the disclosure on 2 November 2026.
- If the management interface was exposed to the internet, check for unexpected logins or requests from unknown IP addresses.
Sources
Related posts
Alerts ·
OpenSSH on Alpine Linux: login without password via overlong passwords
On Alpine Linux servers with the standard openssh-server package, attackers can log in to accounts without a password, such as key-only accounts. OpenSSH 10.6p2 and updated Alpine packages fix it.
Alerts ·
APT flaw on Debian and Ubuntu lets MitM attackers swap packages and run code as root
A flaw in APT lets an attacker who can modify package downloads replace a verified package and run code as root. Debian and Ubuntu published advisories on November 4. Update APT on all servers.
Alerts ·
Ruby on Rails Active Storage: critical file write flaw via ImageMagick uploads
A critical flaw in Ruby on Rails Active Storage lets unauthenticated attackers write arbitrary files on the server through a crafted upload when ImageMagick processes it. Update to Rails 8.1.4.1 or 8.0.5.2.