Security alert · Critical
Drupal Commerce Core authorization bypass actively exploited (CVE-2026-118539)
· 2 minutes read · Centoculus Security Team
Known since · attacks confirmed since
Affected: Drupal Commerce Core up to 2.41 and 3.0.0 to 3.3.13
What happened
On 30 October 2026 the Drupal security team published advisory SA-CONTRIB-2026-254 for Commerce Core, the contributed module that powers most Drupal-based web shops. The vulnerability, tracked as CVE-2026-118539, is a missing authorization check that allows forceful browsing. An attacker can open pages or functions directly by URL that should only be available to users with the right permissions.
Active exploitation was confirmed on the same day the vulnerability became public. Shops that have not yet updated are at immediate risk.
Who is affected
The vulnerability affects every Drupal site with Commerce Core installed in one of these versions:
- Commerce Core up to version 2.41
- Commerce Core from version 3.0.0 to 3.3.13
Drupal core itself is not named as affected. The risk comes from the Commerce Core module. If you manage Drupal shops for customers, check each site individually, because module versions often differ between installations.
What to do now
- Find out which Commerce Core version each site runs, for example with
composer show drupal/commerceordrush pm:list | grep -i commerce. - Back up the database and the codebase, including
composer.jsonandcomposer.lock. - Look up the fixed release for your branch in the Drupal advisory SA-CONTRIB-2026-254 linked below. The fixed version numbers are not included in our source data, so do not rely on a guessed version.
- Update the module, for example with
composer update drupal/commerce --with-dependencies, then deploy the updated code. - Run pending database updates and clear the cache:
drush updatedbanddrush cache:rebuild. - Test the shop: product pages, cart, checkout, payment and the administration pages for orders and stores.
- If you cannot update immediately, consider putting the shop into maintenance mode until the update is installed.
How to check whether you are affected
- Version check: any Commerce Core version up to 2.41, or from 3.0.0 to 3.3.13, is vulnerable.
- Access logs: review the web server access logs since before 30 October 2026. Look for requests to Commerce-related administrative or order routes that come from anonymous visitors or from accounts that should not have access to them.
- Drupal logs: check the recent log messages (
/admin/reports/dblogordrush watchdog:show) for unusual activity. - Shop data: look for orders, prices, products, store settings or payment configuration that changed without explanation. Also check for user accounts or role changes that nobody on your team made.
- If you find signs of misuse: preserve the logs, rotate administrator and API credentials, and inform the shop owner. Depending on what data was accessed, data protection notification duties may apply.
Sources
If you run CMS or shop systems, also check
- WordPress plugin vulnerabilities: 5 plugins, including LiteSpeed Cache
- WordPress plugin vulnerabilities: 6 plugins affected, including SureCart
- WordPress core race condition lets attackers run code during upgrades, actively exploited
- WordPress update fixes code injection flaw, exploitation attempts observed
- WordPress plugin vulnerabilities: 19 plugins including W3 Total Cache
- WordPress plugin vulnerabilities: 10 plugins, including Welcart e-Commerce
- Magento stores hit by evasive JavaScript loader hidden in CMS blocks
- CryptoPayment Gateway WordPress plugin flaw CVE-2026-81648 now actively exploited
- Adobe Commerce and Magento: exploited file upload flaw allows code execution
Related posts
Alerts ·
OpenSSH on Alpine Linux: login without password via overlong passwords
On Alpine Linux servers with the standard openssh-server package, attackers can log in to accounts without a password, such as key-only accounts. OpenSSH 10.6p2 and updated Alpine packages fix it.
Alerts ·
APT flaw on Debian and Ubuntu lets MitM attackers swap packages and run code as root
A flaw in APT lets an attacker who can modify package downloads replace a verified package and run code as root. Debian and Ubuntu published advisories on November 4. Update APT on all servers.
Alerts ·
Ruby on Rails Active Storage: critical file write flaw via ImageMagick uploads
A critical flaw in Ruby on Rails Active Storage lets unauthenticated attackers write arbitrary files on the server through a crafted upload when ImageMagick processes it. Update to Rails 8.1.4.1 or 8.0.5.2.