Security alert · Critical
WordPress core race condition lets attackers run code during upgrades, actively exploited
· 3 minutes read · Centoculus Security Team
Known since · attacks confirmed since
Affected: WordPress Core (see vendor advisory for affected and fixed versions)
What happened
On 31 October 2026 a vulnerability in WordPress core became public, tracked as CVE-2026-119977. It is a time-of-check time-of-use (TOCTOU) race condition in the way WordPress performs full-package core upgrades. During such an upgrade, WordPress uses staging paths that are predictable and reachable over the web. An unauthenticated attacker who hits these paths during the upgrade window can execute code on the server.
On 3 November 2026 CISA added the vulnerability to its catalogue of actively exploited vulnerabilities. Attacks are therefore happening now. No CVSS score has been published yet.
Who is affected
All WordPress installations running an affected core version are at risk, regardless of theme or plugins. The attack does not need a login. The vulnerable moment is the full-package core upgrade itself, so sites that update core automatically or on a schedule are exposed every time such an upgrade runs.
The vendor release announcement linked below refers to WordPress 7.1.4. Check it and the linked advisories for the exact affected and fixed versions, including any fixes for older branches.
What to do now
- Make a quick backup of the site files,
wp-config.phpand the database. - Check the vendor advisory linked below and identify the fixed version for the branch you run.
- Update WordPress core to the fixed version, for example with
wp core updatevia WP-CLI or from the dashboard. Because the weakness lies in the upgrade window, run the update at a quiet time and do not leave it half finished. - If you manage many sites, update them promptly and in a controlled way rather than waiting for scheduled automatic updates.
- After the update, confirm the version with
wp core version, load the front end and the admin area, and check the PHP and web server error logs. - If a site ran a core upgrade on an affected version recently, carry out the checks below even after updating, since a compromise during an earlier upgrade is not undone by the patch.
How to check whether you are affected
- Check the installed core version with
wp core versionor under Dashboard > Updates and compare it with the fixed versions in the vendor advisory. - Review the web server access logs around the times of recent core upgrades for requests from unknown addresses to the upgrade staging area (by default below
wp-content/upgrade/). - Look for leftover or unexpected files in
wp-content/upgrade/and for recently changed PHP files in the web root, for example withfind . -name '*.php' -mtime -7. - Run
wp core verify-checksumsto detect modified core files. - Check for unknown administrator accounts (
wp user list --role=administrator), unknown scheduled tasks and unfamiliar plugins. - If you find signs of compromise, take the site offline, preserve the logs for analysis, restore from a clean backup, update, and change all passwords and the keys and salts in
wp-config.php.
Sources
More on WordPress
- WordPress plugin vulnerabilities: 5 plugins, including LiteSpeed Cache
- WordPress plugin vulnerabilities: 6 plugins affected, including SureCart
- WordPress update fixes code injection flaw, exploitation attempts observed
- WordPress plugin vulnerabilities: 19 plugins including W3 Total Cache
- WordPress plugin vulnerabilities: 10 plugins, including Welcart e-Commerce
If you run CMS or shop systems, also check
- Drupal Commerce Core authorization bypass actively exploited (CVE-2026-118539)
- Magento stores hit by evasive JavaScript loader hidden in CMS blocks
- CryptoPayment Gateway WordPress plugin flaw CVE-2026-81648 now actively exploited
- Adobe Commerce and Magento: exploited file upload flaw allows code execution
Related posts
Alerts ·
OpenSSH on Alpine Linux: login without password via overlong passwords
On Alpine Linux servers with the standard openssh-server package, attackers can log in to accounts without a password, such as key-only accounts. OpenSSH 10.6p2 and updated Alpine packages fix it.
Alerts ·
APT flaw on Debian and Ubuntu lets MitM attackers swap packages and run code as root
A flaw in APT lets an attacker who can modify package downloads replace a verified package and run code as root. Debian and Ubuntu published advisories on November 4. Update APT on all servers.
Alerts ·
Ruby on Rails Active Storage: critical file write flaw via ImageMagick uploads
A critical flaw in Ruby on Rails Active Storage lets unauthenticated attackers write arbitrary files on the server through a crafted upload when ImageMagick processes it. Update to Rails 8.1.4.1 or 8.0.5.2.